Back to overview
Resolved
Unplanned Outage - GTMailPlus - Vessel Connections to GT Servers
Jul 16, 2026 at 11:33am UTC
Affected services
Email Services
Resolved
Jul 16, 2026 at 11:33am UTC
Dear Valued Customer,
GT Maritime is currently investigating an issue affecting GTMailPlus, which is causing delays in mail processing and intermittent connection difficulties for vessels.
Mail continues to queue safely and no messages are being lost
GT Maritime is treating this as a high priority and will provide further updates as soon as more information becomes available.
We apologize for any inconvenience you may experience with your communications during this service interruption.
If you have any questions, please do not hesitate to contact one net Support (support@onenet.group, +357 25 828 999 "Option 1").
Affected services