Back to overview
Maintenance

Planned Maintenance - abela.io

Jun 22, 2026 at 7:00am UTC  –  Jun 22, 2026 at 7:45am UTC
Affected services
abela.io

Resolved
Jun 22, 2026 at 7:45am UTC

Maintenance ended

Created
Jun 22, 2026 at 7:00am UTC

Dear Valued Customer,

We will be carrying out scheduled maintenance on Abela.io on Monday, 22 June 2026, to release a number of new features, enhancements, and fixes.

During this maintenance window, users may experience brief periods of service disruption or intermittent availability while the updates are being applied.

Updates will be provided on this page throughout the maintenance window, and we will confirm once all maintenance activities have been completed successfully.

We apologize for any inconvenience you may experience with your communications during this service interruption.
If you have any questions, please do not hesitate to contact one net Support (support@onenet.group, +357 25 828 999 "Option 1").